Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: instantcake cdrom not mounting on any /dev device

  1. #1
    Join Date
    Nov 2008
    Posts
    2

    instantcake cdrom not mounting on any /dev device

    Hi, I'm wondering if anyone else has seen this issue:

    I can boot up fine with the instantcake cd-rom, but I cannot mount the cdrom device to /cdrom. It keeps returning an error that it cannot mount the device. I tried every /dev/sdX device with no luck.

    I reviewed the dmesg output and it seems like the cdrom is being attached to "sr0", but I cannot find this device in /dev.

    Any ideas?

  2. #2
    Join Date
    Nov 2008
    Posts
    2
    I figured out the solution:

    mknod /dev/sr0 b 11 0

  3. #3
    What version of InstantCake are you using?

  4. #4
    Join Date
    Jan 2010
    Posts
    1
    Goldeneye is exactly correct. I admit I was a little disappointed when I found that this product does not mount my SATA drives. I ONLY have SATA and don't want to spend more money to buy a USB CDROM drive.

    So here is what I did to get around the current SATA problem.

    When the program starts

    <Ctrl> C

    next enter:
    mknod /dev/sr0 b 11 0

    that will make the drive. You can test mount this if you want

    next us VI to modify the install script

    vi /usr/sbin/PTVbake3

    Navigate down to the prompts for SATA CDROM

    Put i to enter insert mode

    After "other" enter "sr0"

    Then press esc

    Then : then x then <enter> This will save the script

    To start the script again enter PTVbake3

    Now y, y, SATA, sr0 ......

    This should allow you to get past the check. If the CDRom spins up your should be in good shape.

    Cheers
    Justin

  5. #5
    Join Date
    May 2010
    Posts
    1

    good....bad

    Justin- you rock. I couldn't get anything else to work then I found this post and tried it. Will spread the word elsewhere.
    I used IC for the THD. Had no problems once I created the "sr0" drive. Now my THD has 2TB and a new lease on life.

    Dissappointed in the execution of this software. It was not the "chipset" as discussed in other posts, but I needed the ability to "see" where my CDR was mounted and add that to the script.

    I get where it clearly says this is a DIY product, and don't do this if voiding warranties makes you cry like a schoolgirl. I went in eyes wide open on that. However based on my experience this statement would be more proper: "You may have to have a basic knowledge and comfort level of mounting drives, vi script editing in Linux to be successful". to the product's credit after I used this workaround everything else worked quickly, as designed, and as advertised.

  6. #6
    Join Date
    May 2010
    Posts
    1
    Thanks for the great info. We had this same problem, but solved it a different way. In the AMI bios, we turned off ACHI and then the drives showed up as IDE. I ran the Instantcake boot disk again, exited out of the script (I still didn't know what the drive letters where), then ran demesg | less and found the drive mappings. I ran instantcake yet again (getting pretty good at it now!) from the command line and it worked!! YAHOOOO! I have a 1.2 TB drive running on my formerly dead TivoHD and I'm thrilled it worked!

  7. #7
    Join Date
    Jul 2010
    Posts
    1
    thanks for the post

  8. #8
    Join Date
    Aug 2010
    Posts
    1
    TXjustin982, first thanks for posting this, I was going crazy trying to get this figured out.

    I am new to this and am not sure where exactly to enter "sr0" also when i hit escap x and enter nothing happens, I cant seem to get out of the editor, any suggestions?

    Again, thanks for the post and if you have any more input to help me get past this it would be much appreciated.

  9. #9
    Join Date
    Oct 2010
    Posts
    6
    Quote Originally Posted by txjustin1982 View Post
    After "other" enter "sr0"
    Talk about dusting off my old vi skills, but ... I own two PCs and both are 100% SATA, and that one line about entering sr0 "after" other has me totally confused.

    Line 232 look like this:
    Code:
     echo " other  ------> other"
    Changing that to the following didn't work at all:
    Code:
     echo " other  ------> sr0"
    It's as if the PTVbake3 file isn't being saved ... What other options do I have here?

  10. #10
    Join Date
    Oct 2010
    Posts
    6

    Success!

    OK, worked it out ...

    Lines 231-234 start as:
    Code:
     echo " Device 4 ----> sdd"
     echo " other  ------> other"
     echo ""
     prompt_in " Please select from the following:" "sda" "sdb" "sdc" "sdd" "other"
    Change them to:
    Code:
     echo " Device 4 ----> sdd"
     echo " other  ------> sr0"
     echo ""
     prompt_in " Please select from the following:" "sda" "sdb" "sdc" "sdd" "sr0"
    Now I'm going to plug the drive into my TiVo. Wish me luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •