Results 1 to 6 of 6

Thread: Problems mounting CDrom in instant cake

  1. #1

    Problems mounting CDrom in instant cake

    Does anybody know of an easy way to detect drive letters or numbers for a cd rom in instant cake. I am trying to replace a dead drive in a series 3. I have tried my hp laptop and 2 other computers and have had no luck getting the program to mount the cd rom. I have tried all the combinations that I can think of. On one computer I used, I tried all of the letter designations under SATA since my cdrom is a SATA. I tried to add sr0 as goldeneye described but was unable to save the changes. Surely there is a command that will read the cdrom and tell how it is configured. Anybody got any ideas.

  2. #2
    taken from tbox:

    My HD Tivo died two days a go and, like others, I was told it would cost $150 and up to either replace or fix. I did try to dd_rescue but the drive was trashed. I'm too impatient so I purchased the $19.99 ISO InstantCake image. I had a lot of difficulty *just* using the InstantCake cdrom because my computer has a RAID and I didn't have an IDE option - just SATA. This post details the steps I used to make a new TIVO drive using a computer with only SATA (no IDE).

    First, unzip the ISO. I use Winzip. After downloading the .zip, unzip and you'll have another "zipped" file with the extension .ISO. Unzip that one and you'll see the files and folders.
    Copy the InstantCake image to a flash/thumbdrive. Put it in the root of the thumbdrive for ease (but you can have other stuff on the drive). The image is found in your InstantCake files under /_images. It's the really big 000001 file.
    Go over to mfslive.org and download their mfslive ISO (you'll need to register on their forum to access this file).
    Burn the mfslive ISO to a cd. I use CyberLink Power2Go and chose the option "Burn disk image."
    Set up the computer on which you'll be doing your work. Turn the computer off first and unplug the power cable. Then, unplug the computer's hard drive and plug in the new TIVO SATA drive. Make sure your BIOS is set up to boot to cdrom.
    Start the computer with the MFSLIVE cd in the cdrom drive. After it finishes scrolling through all of the details about your computer, use SHIFT-PAGE UP/DOWN to locate the place where it assigned your new TIVO hard drive a sd* designation. Mine was sda.
    Plug your USB thumbdrive in and you'll see the Linux system assign that drive a sd* designation. Here was the trick for me - my thumbdrive was sdb but I had to point to the first partition to mount it.
    Mount the thumbdrive. I used this code:
    mount -t vfat /dev/sdb1 /dos
    Check that you can see your 00001 file by typing cd /dos and then ls.
    Use the following command to transfer the InstantCake from the thumbdrive to your new TIVO drive:
    restore -s 128 -xzpi /dos/00001 /dev/sda (<-or whatever your sd* is)


    That's it! It finished rather quickly (~1minute?) and then I plugged the drive back into my TIVO. During setup, I called my cable provider (Comcast) and had them ping my cablecards. Done!

    I hope this helps someone. This is basically a distillation of the procedure found here (MANY THANKS!!), with minor tweaks. I did, however, want to post this for anyone having trouble with SATA-only components which can't mount the cdrom or other drives just using the InstantCake cd.

    Good luck!

    Make sure the flash drive is formatted as FAT, not FAT32 (might be okay) and NOT NTFS. I can comfirm that it worked for me. I have an HP Laptop and connected my harddrive via a SATA TO USB drive

  3. #3

    Talking That was the trick!

    That was just the info I needed! Thanks for the great info!

  4. #4

    Unable to open for writing

    I made it all the way to the "restore" command. My thumb drive ended up being sde1 (discovered after much trial and error). For the target blank hard drive (1TB), I tried /dev/sda, sdb, sdc, sdd and sdf, to no avail.

    Perhaps a different approach - is there a way to burn the 00001 image from the thumb drive (mounted or not) to the blank SATA hard drive using MFSTools or similar freeware?
    Last edited by Rulison; 01-04-2012 at 01:25 PM.

  5. #5

    restore failed.. no such file

    I got to mount the USB drive, and I had to mount the HD with USB as well.

    it give me an error and it says /dev/sdb113: no such file or directory at 95.05 comp

    What is going on?

    Thanks.

  6. #6

    Frustrated

    Software is out dated and customer service does not help. I've tried all the above and none of it works. A total waste of $40.00.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •